Skip to main content

Installing Oracle 12cR2 Database on RHEL 7 in si

 In this blog, we will look at steps to install the Oracle 12cR2 Database silently on RHEL 7.


1. Create the response file under /tmp

vi /tmp/12cR2_response.rsp

Do not forget to replace ORACLE_HOSTNAME, ORACLE_HOME and ORACLE_BASE location in the below file
oracle.install.responseFileVersion=/oracle/install/rspfmt_dbinstall_response_schema_v12.2.0 oracle.install.option=INSTALL_DB_SWONLY ORACLE_HOSTNAME=proddb UNIX_GROUP_NAME=oinstall INVENTORY_LOCATION=/u01/app/oraInventory SELECTED_LANGUAGES=en ORACLE_HOME=/u01/app/oracle/product/12.2.0.1 ORACLE_BASE=/u01/app/oracle oracle.install.db.InstallEdition=EE oracle.install.db.OSDBA_GROUP=dba oracle.install.db.OSOPER_GROUP=dba oracle.install.db.OSBACKUPDBA_GROUP=dba oracle.install.db.OSDGDBA_GROUP=dba oracle.install.db.OSKMDBA_GROUP=dba oracle.install.db.OSRACDBA_GROUP=dba SECURITY_UPDATES_VIA_MYORACLESUPPORT=false DECLINE_SECURITY_UPDATES=true oracle.installer.autoupdates.option=SKIP_UPDATES

2. Go to 12cR2 installation software location and fire the runInstaller in silent mode

./runInstaller -ignoreSysPrereqs -showProgress -silent -responseFile /tmp/12cR2_response.rsp




3. Edit the dbca.rsp file under database/response folder and then run the installer to install the database


dbca -ignorePreReqs -createDatabase -silent -responseFile ./dbca.rsp




4. netca -silent -responseFile ./netca.rsp

netca -silent -responseFile /u01/software/database/response/netca.rsp

Parsing command line arguments:
    Parameter "silent" = true
    Parameter "responsefile" = /u01/software/database/response/netca.rsp
Done parsing command line arguments.
Oracle Net Services Configuration:
Profile configuration complete.
Oracle Net Listener Startup:
    Running Listener Control:
      /u01/app/oracle/product/12.2.0.1/bin/lsnrctl start LISTENER
    Listener Control complete.
    Listener started successfully.
Listener configuration complete.
Oracle Net Services configuration successful. The exit code is 0










Comments

Popular posts from this blog

How to install Apache using Ansible

How to install Apache using Ansible Use the powerful ansible tool to install Apache on your local machine or you can install on any remote server as well. 1. Install Ansible Modules [root@dev02 ~]# yum install ansible* Oracle Linux 8 EPEL Packages for Development (x86_64)                                                                                                             1.5 kB/s | 2.5 kB     00:01 Oracle Linux 8 Gluster Appstream (x86_64)                                                                        ...

CLEARING an ADOP patching session

In some case adop prepare phase fails due to some issues and if you wish to apply any patch in hotpatch mode, it will fail with below errors [STATEMENT] There is already a session which is incomplete. Details are: [STATEMENT]     Session Id: 2 [STATEMENT]     Prepare phase status: R [STATEMENT]     Apply phase status: N [STATEMENT]     Cutover  phase status: N [STATEMENT]     Abort phase status: N [STATEMENT]     Session status: F [ERROR]     Cannot apply hotpatch as another online patching cycle is going on [ERROR]     Unrecoverable error occured. Exiting the current session. [STATEMENT] [START 2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] [END   2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] Log file: /adop_20191022_161221.log [STATEMENT] [START 2019/10/22 16:13:02] Unlocking sessions table [STATEMENT] [E...

MongoDB - How to Install MongoDB on Linux

MongoDB - How to Install MongoDB on Linux Please follow the below steps to Install MongoDB Enterprise Edition on Linux: 1.Configure repository. Create an  /etc/yum.repos.d/mongodb-enterprise.repo  file so that you can install MongoDB enterprise directly using  yum : [mongodb-enterprise] name = MongoDB Enterprise Repository baseurl = https://repo.mongodb.com/yum/redhat/$releasever/mongodb-enterprise/4.2/$basearch/ gpgcheck = 1 enabled = 1 gpgkey = https://www.mongodb.org/static/pgp/server-4.2.asc You can also download the  .rpm  files directly from the  MongoDB repository . 2. Install the MongoDB Enterprise packages. Install MongoDB Enterprise 4.2. Issue the following command: copy copied sudo yum install -y mongodb-enterprise