Skip to main content

19c RMAN-04006: error from auxiliary database: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor

 19c RMAN-04006: error from auxiliary database: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor


Before doing an RMAN DUPLICATE DATABASE from an Active Database, we need to set up listener on the target environment with static registration.  Else when the RMAN shuts down the auxiliary database for creating spfile or making changes in it, it will not be able to connect the auxiliary and start the database (nomount) and throw the error :


RMAN-04006: error from auxiliary database: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor


To Solve this issue ensure that listener is configured with static registration using the below syntax :

========= LISTENER.ORA==================

EBSUPG=

  (DESCRIPTION_LIST =

    (DESCRIPTION =

      (ADDRESS = (PROTOCOL = TCP)(HOST =<hostname>)(PORT = 1536))

      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1536))

    )

  )



SID_LIST_EBSUPG=

  (SID_LIST =

    (SID_DESC =

      (GLOBAL_DBNAME = EBSUPG)

      (ORACLE_HOME = /u01/app/oracle/product/19.0.0/dbhome_1)

      (SID_NAME = EBSUPG)

    )

  )


ADR_BASE_LISTENER_EBSUPG = /u01/app/oracle

=================================================================

When we check the listener status, it should show as UNKNOWN instead of BLOCKED 

-bash-4.4$ lsnrctl status EBSUPG

LSNRCTL for Solaris: Version 19.0.0.0.0 - Production on 30-SEP-2022 13:57:46

Copyright (c) 1991, 2021, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=10.92.27.104)(PORT=1536)))
STATUS of the LISTENER
------------------------
Alias                     EBSUPG
Version                   TNSLSNR for Solaris: Version 19.0.0.0.0 - Production
Start Date                30-SEP-2022 13:35:31
Uptime                    0 days 0 hr. 22 min. 14 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   /u01/app/oracle/product/19.0.0/dbhome_1/network/admin/listener.ora
Listener Log File         /u01/app/oracle/diag/tnslsnr/STDBY4BKP/ebsupg/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=hostname)(PORT=1536)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC1536)))
Services Summary...
Service "EBSUPG" has 1 instance(s).
  Instance "EBSUPG", status UNKNOWN, has 1 handler(s) for this service...
The command completed successfully

This solved my issue and it started with the ACTIVE DUPLICATE.

Comments

Popular posts from this blog

How to install Apache using Ansible

How to install Apache using Ansible Use the powerful ansible tool to install Apache on your local machine or you can install on any remote server as well. 1. Install Ansible Modules [root@dev02 ~]# yum install ansible* Oracle Linux 8 EPEL Packages for Development (x86_64)                                                                                                             1.5 kB/s | 2.5 kB     00:01 Oracle Linux 8 Gluster Appstream (x86_64)                                                                        ...

CLEARING an ADOP patching session

In some case adop prepare phase fails due to some issues and if you wish to apply any patch in hotpatch mode, it will fail with below errors [STATEMENT] There is already a session which is incomplete. Details are: [STATEMENT]     Session Id: 2 [STATEMENT]     Prepare phase status: R [STATEMENT]     Apply phase status: N [STATEMENT]     Cutover  phase status: N [STATEMENT]     Abort phase status: N [STATEMENT]     Session status: F [ERROR]     Cannot apply hotpatch as another online patching cycle is going on [ERROR]     Unrecoverable error occured. Exiting the current session. [STATEMENT] [START 2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] [END   2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] Log file: /adop_20191022_161221.log [STATEMENT] [START 2019/10/22 16:13:02] Unlocking sessions table [STATEMENT] [E...

MongoDB - How to Install MongoDB on Linux

MongoDB - How to Install MongoDB on Linux Please follow the below steps to Install MongoDB Enterprise Edition on Linux: 1.Configure repository. Create an  /etc/yum.repos.d/mongodb-enterprise.repo  file so that you can install MongoDB enterprise directly using  yum : [mongodb-enterprise] name = MongoDB Enterprise Repository baseurl = https://repo.mongodb.com/yum/redhat/$releasever/mongodb-enterprise/4.2/$basearch/ gpgcheck = 1 enabled = 1 gpgkey = https://www.mongodb.org/static/pgp/server-4.2.asc You can also download the  .rpm  files directly from the  MongoDB repository . 2. Install the MongoDB Enterprise packages. Install MongoDB Enterprise 4.2. Issue the following command: copy copied sudo yum install -y mongodb-enterprise