Skip to main content

Add disk in virtual box vm

 Add disk in virtual box vm 


In this post, we will check how to add disks in Virtual Box VM. 


1. First add the disk from VM console as a new HDD as shown below:

We have recently added oel76_db1.vdi disk.


2. Once the disk is added, it will be visible in fdisk -l command output. 

3. create the partion using below command

fdisk /dev/sdb 

for new partion : type n, 

to list partition : type p

to write the partion : type w


4. Format the partition by below command:

Now format the disk with mkfs command.

# mkfs.ext4 /dev/sdb1

[root@oel76 etc]# mkfs.ext4 /dev/sdb1

mke2fs 1.42.9 (28-Dec-2013)

Filesystem label=

OS type: Linux

Block size=4096 (log=2)

Fragment size=4096 (log=2)

Stride=0 blocks, Stripe width=0 blocks

15032320 inodes, 60108800 blocks

3005440 blocks (5.00%) reserved for the super user

First data block=0

Maximum filesystem blocks=2208301056

1835 block groups

32768 blocks per group, 32768 fragments per group

8192 inodes per group

Superblock backups stored on blocks:

        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,

        4096000, 7962624, 11239424, 20480000, 23887872


Allocating group tables: done

Writing inode tables: done

Creating journal (32768 blocks): done

Writing superblocks and filesystem accounting information: done


[root@oel76 etc]#


5. mount the disk using below command:

mount /dev/sdb1 /u02


6. Add entry in /etc/fstab file to automatically mount the disk during startup

/dev/sdb1               /u02                    ext4    defaults        0 0

Comments

Popular posts from this blog

How to install Apache using Ansible

How to install Apache using Ansible Use the powerful ansible tool to install Apache on your local machine or you can install on any remote server as well. 1. Install Ansible Modules [root@dev02 ~]# yum install ansible* Oracle Linux 8 EPEL Packages for Development (x86_64)                                                                                                             1.5 kB/s | 2.5 kB     00:01 Oracle Linux 8 Gluster Appstream (x86_64)                                                                        ...

CLEARING an ADOP patching session

In some case adop prepare phase fails due to some issues and if you wish to apply any patch in hotpatch mode, it will fail with below errors [STATEMENT] There is already a session which is incomplete. Details are: [STATEMENT]     Session Id: 2 [STATEMENT]     Prepare phase status: R [STATEMENT]     Apply phase status: N [STATEMENT]     Cutover  phase status: N [STATEMENT]     Abort phase status: N [STATEMENT]     Session status: F [ERROR]     Cannot apply hotpatch as another online patching cycle is going on [ERROR]     Unrecoverable error occured. Exiting the current session. [STATEMENT] [START 2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] [END   2019/10/22 16:13:00] Unlocking sessions table [STATEMENT] Log file: /adop_20191022_161221.log [STATEMENT] [START 2019/10/22 16:13:02] Unlocking sessions table [STATEMENT] [E...

MongoDB - How to Install MongoDB on Linux

MongoDB - How to Install MongoDB on Linux Please follow the below steps to Install MongoDB Enterprise Edition on Linux: 1.Configure repository. Create an  /etc/yum.repos.d/mongodb-enterprise.repo  file so that you can install MongoDB enterprise directly using  yum : [mongodb-enterprise] name = MongoDB Enterprise Repository baseurl = https://repo.mongodb.com/yum/redhat/$releasever/mongodb-enterprise/4.2/$basearch/ gpgcheck = 1 enabled = 1 gpgkey = https://www.mongodb.org/static/pgp/server-4.2.asc You can also download the  .rpm  files directly from the  MongoDB repository . 2. Install the MongoDB Enterprise packages. Install MongoDB Enterprise 4.2. Issue the following command: copy copied sudo yum install -y mongodb-enterprise